common: Require libusb/libusbx >= 1.0.13

We technically need 1.0.12 or newer, but there's no way to detect that
at compile time since there was no VERSION definition in the libusb
headers until 1.0.13
This commit is contained in:
Solomon Peachy 2014-02-03 11:28:13 -05:00
parent 11cd411855
commit 2b867a323a
2 changed files with 6 additions and 2 deletions

2
README
View File

@ -93,7 +93,7 @@
***************************************************************************
Compilation:
You will need libusbx to build this tool.
You will need libusb/libusbx v1.0.13 (or newer) to build this tool.
Fedora/RedHat:
yum install libusbx-devel

View File

@ -27,11 +27,15 @@
#include "backend_common.h"
#define BACKEND_VERSION "0.31"
#define BACKEND_VERSION "0.32"
#ifndef URI_PREFIX
#error "Must Define URI_PREFIX"
#endif
#ifndef LIBUSBX_API_VERSION
#error "We need libusb >= 1.0.13!"
#endif
/* Support Functions */
#define ID_BUF_SIZE 2048