Gutenprint + CUPS backends for Dye Sublimation printers
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
Solomon Peachy 26f766c129 lib70x: Update documentation to include the D70-S/D707-S variants 5 months ago
..
data Kodak305: updated CPC data files 1 year ago
Makefile build: Improvements around testing 3 years ago
README lib70x: Update documentation to include the D70-S/D707-S variants 5 months ago
libMitsuD70ImageReProcess.c Update copyright year on a few files 1 year ago
libMitsuD70ImageReProcess.h lib70x: Library enhancements for CP30D family 2 years ago

README

   LibMitsuD70ImageReProcess -- Re-implemented image processing library for
the Mitsubishi CP-D70 family of printers

Copyright (c) 2016-2021 Solomon Peachy <pizza@shaftnet.org>

** ** ** ** Do NOT contact Mitsubishi about this library! ** ** ** **

This library is a platform-independent reimplementation of the image
processing algorithms that are necessary to utilize the Mitsubishi
CP-D70, CP-M1, CP9800, and CP30 families of printers.

Mitsubishi was *NOT* involved in the creation of this library, and is
not responsible in any way for the library or any deficiencies in its
output. They will provide no support if it is used.

However, without this library, it is nearly impossible to utilize the
the above families of printers under Linux and similar operating
systems.

The following printers are known to utilize this library:

* Mitsubishi CP-D70DW
* Mitsubishi CP-D707DW
* Mitsubishi CP-D70DW-S
* Mitsubishi CP-D707DW-S
* Mitsubishi CP-K60DW-S
* Mitsubishi CP-D80DW
* Mitsubishi CP-M1
* Mitsubishi CP-M15
* Mitsubishi CP30DW
* Mitsubishi CP9800DW [*1]
* Mitsubishi CP9810DW [*1]
* Mitsubishi CP9820DW-S [*1]
* Kodak 305
* Fujifilm ASK-300
* Fujifilm ASK-500 [*2]

[*1] The CP98xx family is expected to function, but likely has
bugs affecting the output quality.
[*2] The ASK500 is expected to function but has not been tested.

** ** ** **

This library is released under the GNU GPL version 3. Unfortunately
this means that it cannot be bundled with Gutenprint.

In order to utilize this library with Gutenprint, you will need:

* Gutenprint 5.2.12-pre4 or newer
* Current selphy_print backend
* This library

To build this library:

make
make install

You may also need to add the library to the search path:

echo "/usr/local/lib" >> /etc/ld.so.conf
ldconfig